Compartilhe
Ir em baixo
Admin
Mensagens : 3
Data de inscrição : 05/12/2018
Ver perfil do usuáriohttp://examefinalal.forumeiros.com

P3 -- Exame final de andré

em Qua Dez 05, 2018 10:40 am
Prazo:
10.12.2018 - 2359h

Importante
Postar questões para prova para P3
Tem que ter vetor em todas as questões


o que vai cair na prova?
vai ter uma questão de múltipla escolha , questão de dizer o que vai acontecer no algoritmo e montar algoritmo na prova.
Mensagens : 1
Data de inscrição : 06/12/2018
Ver perfil do usuário

Re: P3 -- Exame final de andré

em Qui Dez 06, 2018 9:46 pm
Quais serão as variáveis escritas no algoritmo ?
Algoritmo " vetor "
Var
Numero : vetor [0..4] de inteiro
i : inteiro
Inicio
Para i de 1 ate 5 faça
Numero[i -1] <- i
Fimpara
Para i de 5 ate 1 passo -1 faça
Escreval (numero [5 - i])
Fimpara
Fimalgoritmo


Última edição por Yuri Rodrigues de Farias em Dom Dez 09, 2018 10:45 am, editado 2 vez(es)
Mensagens : 1
Data de inscrição : 07/12/2018
Ver perfil do usuário

QUESTÃO PARA P3

em Sex Dez 07, 2018 11:27 pm
Faça um algoritmo que copie o conteudo de um vetor em um segundo vetor.

algoritmo "exercicios"
var
i:inteiro
vetA:vetor[1..5] de inteiro
vetB:vetor[1..5] de inteiro
inicio
para i de 1 ate 5 faça
leia(vetA[i])
fimpara
para i de 1 ate 5 faça
vetB[i]<-vetA[i]
fimpara
fimalgoritmo

Faça um algoritmo que some o conteudo de 2 vetores  e armazene o resultado em um terceiro vetor.

algoritmo "exercicios"
var
i:inteiro
vetA:vetor[1..5] de inteiro
vetB:vetor[1..5] de inteiro
vetC:vetor[1..5] de inteiro
inicio
para i de 1 ate 5 faça
leia(vetA[i])
fimpara
para i de 1 ate 5 faça
leia(vetB[i])
fimpara
para i de 1 ate 5 faça
vetC[i]<-vetA[i]+vetB[i]
fimpara
fimalgoritmo




Última edição por Davi lima em Dom Dez 09, 2018 10:27 pm, editado 1 vez(es)
Mensagens : 1
Data de inscrição : 09/12/2018
Ver perfil do usuário

Re: P3 -- Exame final de andré

em Dom Dez 09, 2018 7:49 pm
Igor Andrade dos Santos RA 330503811025  2 periodo

Crie um algoritmo que leia um vetor de 10 números inteiros. Em seguida, calcule e escreva o somatório dos valores deste vetor.

Algoritmo "10 numeros"

Var

v: vetor[1..10] de inteiro
i,n,soma:inteiro

Inicio

 para i:=1 ate 10 faca
     escreval("Digite o ",i," valor desejado")
     leia(n)
     soma<-soma+n
  fimpara
  escreval(" A soma dos valores é: ",soma)

Fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

Aline Ramos Antunes, 2°série, RA:330982311025

em Seg Dez 10, 2018 10:07 am
Faça um algoritmo que leia 5 valores e imprima o maior valor. Utilizando vetor, escreva, leia, se e para.


Código:
Algoritmo "maior"

Var
  i : inteiro
  a, b : vetor [1..5] de inteiro
  maior, contador: real

Inicio
  para i de 1 ate 5 faça
     leia (a [i])
     se (a[i] > maior) entao
        maior <- a [i]
        contador <- i
     fimse
  fimpara
  escreval ("O maior valor foi", maior)

Fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

P3 Andre

em Seg Dez 10, 2018 1:09 pm
Faça um algoritmo que criará um vetor com 10 posições e armazenará , em cada posição, o valor subsequente ao seu índice. O vetor será impresso em ordem crescente.

Algoritmo "subsequente"
Var
numero : vetor[0..9] de inteiro
i: inteiro
Inicio
para i de 1 ate 10 faça
numero[i - 1] <-i
fimpara
para i de 10 ate 1 passo -1 faça
escreval(numero[10 - i])
fimpara
Fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

Richardson Emidio Lima - 1° (168.115.037-93) Para P3

em Seg Dez 10, 2018 2:52 pm
Escreva um algoritmo que solicite ao usuário a entrada de 5 nomes, e que exiba a lista desses nomes na tela.
Após exibir essa lista, o programa deve mostrar também os nomes na ordem inversa em que o usuário os digitou, um por linha.


Algoritmo "nomes"

Var
nomes : vetor [0..4] de caractere
cont : inteiro

inicio
para cont de 0 ate 4 faca
  escreval("Entre com um nome:")
  leia(nomes[cont])
fimpara

escreval()
escreval("Os nomes digitados foram:")

para cont de 0 ate 4 faca
  escreval(nomes[cont])
fimpara
escreval()

escreval("Os nomes digitados em ordem inversa foram:")
para cont de 4 ate 0 passo - 1 faca
  escreval(nomes[cont])
fimpara
Fimalgoritmo
Admin
Mensagens : 3
Data de inscrição : 05/12/2018
Ver perfil do usuáriohttp://examefinalal.forumeiros.com

Re: P3 -- Exame final de andré

em Seg Dez 10, 2018 6:28 pm
Faça dois algoritmo que faça a tabuada de qualquer número uma tendo três vetores e outra sem vetor:

Com vetor

Código:
algoritmo "tabuada com vetor"
var
a,b,c:vetor [1..10] de inteiro
n,i:inteiro
inicio
escreval ("quer saber tabuda de qual número? ")
leia (n)
para i de 1 ate 10 faca
a[i]<-n
b[i]<-i
c[i]<-a[i]*b[i]
fimpara
para i de 1 ate 10 faca
escreval (a[i]," *",b[i]," =",c[i]," ")
fimpara
fimalgoritmo

Sem vetor

Código:
algoritmo "semnome"
var
a,b,i:inteiro
inicio
escreval ("digite qualquer número")
leia (a)
para i de 1 ate 10 faça
b<-i
escreval (a," *",b," =",a*b," ")
fimpara
fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

Re: P3 -- Exame final de andré

em Seg Dez 10, 2018 8:35 pm
Altere os ultimos 8 digitos, pelos primeiros 8 digitos Algoritmo

Var
v:vetor[1..16] de inteiro
i, aux: inteiro

Inicio
para i de 1 ate 16 faca
leia (v[i])
fimpara

para i de 1 ate 8 faca
aux <- v[i]
v[i] <- v[i+8]
v[i+8] <- aux

fimpara
escreval("troca")
para i de 1 ate 16 faca
escreval (v[i])
fimpara


Fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

P3 ANDRÉ

em Seg Dez 10, 2018 10:00 pm
1. Faça um algoritmo para gerar um vetor de 30 posições, onde cada elemento corresponde ao quadrado de sua posição. Imprima depois o vetor resultante.

Código:
algoritmo "Indice do vetor ao quadrado"
 //Função Faça um algoritmo para gerar um vetor de 30 posições, onde cada elemento
// corresponde ao quadrado de sua posição. Imprima depois o vetor resultante.

var
indice:inteiro
p30:          vetor [1..30] de real

inicio
para indice de 1 ate 30 faca
     p30[indice]<-(indice^2)
     escreval(p30[indice])
fimpara

fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

P3 ANDRE

em Seg Dez 10, 2018 10:17 pm
Faça um algoritmo com 10 posições e exibi-os em ordem inversa

algoritmo "vetor_invertido"
var
indice:inteiro
p10:vetor [1..10] de inteiro
inicio
para indice de 1 ate 10 faca
escreva(" Digite o ",indice,"º Nº:")
leia(p10[indice])
fimpara
para indice de 10 ate 1 passo -1 faca
escreval("posição do",indice,"ºN :",p10[indice])
fimpara
fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

Rafaela Medeiros Moreno - Exame Final André

em Seg Dez 10, 2018 11:02 pm
Enunciado

Faça um algoritmo que crie um vetor com 50 posições e carregue os valore múltiplos de 5, 10, 15 em diante. Utilize o comando enquanto. Imprima o final o valor da posição
de 25

Algoritmo "multiplos"

Var

  valor: vetor [1..50] de inteiro
  i : inteiro

Inicio

  enquanto(i<50)faça

     i <- i+1
     valor [i] <- i * 5

  fimenquanto
escreval(" a posição 25 é", valor [25])

Fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

Gayo Merlo Soares - Exame Final André

em Seg Dez 10, 2018 11:09 pm
Faça um algoritmo que leia o nome e a média de 5 alunos onde cada aluno é um número. Dependendo do número selecionado o programa deverá imprimir o nome e a média do aluno.

Algoritmo "semnome"

Var
nome: vetor [1..5] de caracter
media: vetor [1..5] de real
i: inteiro

Inicio
para i de 1 ate 5 faça
escreval ("Digite o nome do aluno:")
leia (nome[i])
escreval ("Digite a média:")
leia (media[i])
fimpara
escreval ("Digite o número do aluno:")
leia (i)
escreval (nome[i])
escreval (media[i])

Fimalgoritmo
Mensagens : 1
Data de inscrição : 10/12/2018
Ver perfil do usuário

Paula Simões 5º série RA:171918911025

em Seg Dez 10, 2018 11:20 pm
Questão da P3


"Crie um algoritmo que leia um vetor de 30 números inteiros e gere um segundo vetor cujas posições pares são o dobro do vetor original e as ímpares o triplo."

algoritmo "semnome"
// Função :
// Autor :
// Data : 15/10/2016
// Seção de Declarações
var
v,v2:vetor[1..30] de inteiro
i,tam:inteiro
inicio
tam<-30
para i de 1 ate tam faca
escreval("Digite Um Número E Tecle Enter")
leia(v[i])
fimpara
para i de 1 ate tam faca
se i mod 2=0 então
v2[i]:=v[i]*2
senao
v2[i]:=v[i]*3
fimse
fimpara
fimalgoritmo
Conteúdo patrocinado

Re: P3 -- Exame final de andré

Voltar ao Topo
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum